The Flood Watch for Lego City County has ended, however please use caution as rain is expected to fall after the coming days.
Posted Nov 17, 2025 - 17:42 PST
In progress
The Republic States National Weather Service and the County of Lego City Emergency Department have issued a FLOOD WATCH ALERT from FRIDAY 11/14/25 to MONDAY 11/17/25:
For safety reasons the following service procedures will occur: - Slower Speeds - Additional staff at stations to help you - Some Services Canceled ( Visit alerts.citymetro.xyz for more info) - Use caution when walking through stations, holding handrails, no running, and listening to staff instructions
For More Information Please Visit the City Metro Website. Thank you for understanding.
Posted Nov 15, 2025 - 08:51 PST
Scheduled
The Republic States National Weather Service and the County of Lego City Emergency Department have issued a FLOOD WATCH ALERT from FRIDAY 11/14/25 to MONDAY 11/17/25:
For safety reasons the following service procedures will occur: - Slower Speeds - Additional staff at stations to help you - Some Services Canceled ( Visit alerts.citymetro.xyz for more info) - Use caution when walking through stations, holding handrails, no running, and listening to staff instructions
For More Information Please Visit the City Metro Website. Thank you for understanding.
Posted Nov 15, 2025 - 08:50 PST
This scheduled maintenance affected: Rail Lines Service Alerts (City Metro A Line, City Metro B Line, City Metro D Line, City Metro E Line, City Metro K Line, City Metro F Line), Bus Lines Service Alerts (City Metro Local Bus Line 111, City Metro Local Bus Line 112, City Metro Local Bus Line 113, City Metro Local Bus Line 114 (LEGO THEME PARK SHUTTLE), City Metro Local Bus Line 76, Line 211A/211B), and Republic State Railways Routes (Republic State Railways Route 1).